This project is read-only.

Errors with 1.1 process template

Nov 3, 2011 at 4:18 AM


  I just downloaded and added the process template to source control (TFS 2010).  I get the following error attempting to open the file, and it does not show up in the available process template list :

System.Xaml.XamlException: 'The type ‘InArgument(edam:DeploymentSlot)’ of property ‘Slot’ could not be resolved.' Line number '52' and line position '29'.   at System.Activities.XamlIntegration.DynamicActivityXamlReader.BufferedPropertyList.ActivityPropertyHolder..ctor(DynamicActivityXamlReader parent, XamlReader reader)   at System.Activities.XamlIntegration.DynamicActivityXamlReader.BufferedPropertyList.BufferDefinitions(DynamicActivityXamlReader parent)   at System.Activities.XamlIntegration.DynamicActivityXamlReader.ProcessCurrentNode()   at System.Activities.XamlIntegration.DynamicActivityXamlReader.Read()   at System.Xaml.XamlServices.Transform(XamlReader xamlReader, XamlWriter xamlWriter, Boolean closeWriter)   at System.Activities.Presentation.WorkflowDesigner.DeserializeString(String text, Boolean errorTolerant, IList`1& loadErrors)   at System.Activities.Presentation.WorkflowDesigner.DeserializeString(String text, IList`1& loadErrors)   at System.Activities.Presentation.WorkflowDesigner.Load()

Nov 3, 2011 at 6:16 PM

Just restart Visual studio to pickup new assemblies.

Nov 3, 2011 at 7:36 PM

I rebooted both the client machine and the TFS build machine and I still get the same error.

This error occurs when I attempt to open the DefaultTemplateWithDeploymentToAzure.xaml file from within VS2010 from source control explorer.  

The template also does not show up in the "Build Process file" dropdown in the build definition properties.

Nov 9, 2011 at 3:09 AM

Has anyone else been able to use the 1.1 process template successfully?

Nov 14, 2011 at 8:49 PM

Have you replaced assemblies as well?

If you want to change the template - the best way to to that is to download source code, open and change it in solution and then replace on TFS. 


Nov 15, 2011 at 7:33 PM

Yes, I replaced the assemblies in TFS and pointed to the new assemblies in the build template.

I cannot open the process template in Visual Studio, I receive errors.  When I try to open the 1.0 template in visual studio I can do it without errors.

I am not trying to change the template, just get it to work.  Does the error message I received indicate that the assemblies cannot be located?